Toast Status Update - System Disruption
Incident Report for Toast System
Resolved
This incident has been resolved.
Posted Oct 14, 2019 - 11:54 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 14, 2019 - 11:19 EDT
Investigating
We have been alerted to system issues affecting access to the Toast app and www.toasttab.com. We know that this can significantly impact your operations. Our engineers are investigating the cause and working to resolve the issue as soon as possible. We will update this page as new information is available.
Posted Oct 14, 2019 - 11:13 EDT
This incident affected: Toast POS app.