Toast Status Update - System Disruption
Incident Report for Toast System
Resolved
The Toast system has returned to normal. Thank you for your patience. If you continue to experience issues, please contact Toast Support at (617) 682-0225.
Posted Jul 17, 2019 - 16:10 EDT
Monitoring
The Toast system is returning to normal. We will continue to monitor it closely. Thank you for your patience.
Posted Jul 17, 2019 - 13:50 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 17, 2019 - 13:47 EDT
Investigating
We have been alerted to system issues affecting access to the Toast app. We know that this can significantly impact your operations. Our engineers are investigating the cause and working to resolve the issue as soon as possible. We will update this page as new information is available.
Posted Jul 17, 2019 - 13:41 EDT
This incident affected: Toast POS app.