Toast Status Update - Support Phone Line Disruption
Incident Report for Toast System
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 17:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2024 - 16:09 EDT
Update
We are continuing to investigate this issue. While we work to resolve this issue, you may contact Customer Care using the alternate phone number (949) 524-4482 or the Support tab in the Toast Now app (iOS, Android). We will update this page as soon as the phone lines return to normal.
Posted Apr 30, 2024 - 12:10 EDT
Investigating
We are currently experiencing connection issues with Toast Customer Care phone lines. While we work to resolve this issue, please submit support tickets through Toast Central (central.toasttab.com) or the Support tab in the Toast Now app. We will update this page as soon as the phone lines return to normal.
Posted Apr 30, 2024 - 11:47 EDT
This incident affected: Customer Care Phone Line.