Potential Online Ordering Issue

Incident Report for Toast System

Resolved

This incident has been resolved.
Posted Mar 20, 2024 - 17:23 EDT

Identified

The issue has been identified and we are continuing to work on a fix for this issue.
Posted Mar 20, 2024 - 16:09 EDT

Investigating

We're investigating a technical issue that has led to an incorrect Delivery time quote for some restaurant's online orders.

Our engineers are actively working to understand the root cause and to ensure no additional orders are impacted. We will continue to post additional information on this page as it becomes available.
Posted Mar 20, 2024 - 15:16 EDT
This incident affected: Online Ordering.