Menu Builder and Menu Manager Latency

Incident Report for Toast System

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 17:02 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2025 - 16:54 EST

Identified

We are aware of an issue with Menu Builder and Menu Manager that may result in pages loading slowly or not loading at all. Engineering has identified the cause and are working on implementing a fix.
Posted Dec 09, 2025 - 16:47 EST
This incident affected: POS Web application.