03/17/2025 - Deposit Delay

Incident Report for Toast System

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 13:02 EDT

Update

We are continuing to investigate this issue.
Posted Mar 17, 2025 - 12:29 EDT

Investigating

We're aware of an issue with deposits for a subset of customers. We are alerting you to let you know that you may not have received all or part of your expected deposit today. We expect these funds to be deposited to your account by end of business tomorrow, 3/18.

Thank you for your patience.
Posted Mar 17, 2025 - 12:26 EDT
This incident affected: Deposits.