Your expected deposit for 09/17/2026 and 09/18/2026 may arrive later than usual. We expect these deposits to be completed by end of business today, 09/18/2026 — keep an eye on your bank statement to confirm that your deposit has been made. If you continue to experience issues, please contact us in the Support Center. https://support.toasttab.com/
Posted Sep 18, 2026 - 15:03 EDT
Update
We're monitoring deposits after an issue causing a delay in card deposits for some customers. You may not have received all or part of your expected deposit today. We expect these funds to be deposited to your account by the end of business day, 09/18. Thank you for your patience.
Posted Sep 18, 2026 - 08:55 EDT
Monitoring
We're monitoring deposits after an issue causing a delay in card deposits for some customers. You may not have received all or part of your expected deposit today. We expect these funds to be deposited to your account by the end of business day, 09/18. Thank you for your patience.