(03/20/2025)Performance Degradation Incident

Incident Report for Toast System

Resolved

This incident has now been resolved.
Posted Mar 20, 2025 - 18:29 EDT

Monitoring

We have identified the problem, implemented a fix and are monitoring the results currently.
Posted Mar 20, 2025 - 17:45 EDT

Investigating

We are currently investigating an issue causing degradation and latency within Toastweb and Online Ordering. We are actively working to resolve this as soon as possible.
Posted Mar 20, 2025 - 17:10 EDT
This incident affected: POS Web application and Online Ordering.