Sling Slowness or Failing to Load

Incident Report for Toast System

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 14:22 EST

Investigating

We are currently investigating an issue that may result in Sling pages failing to load or loading slowly for some customers. Refreshing the pages seems to resolve this issue. We are working to resolve this issue as quickly as possibly.
Posted Mar 05, 2026 - 13:41 EST
This incident affected: Sling by Toast Scheduling.