Online Ordering

Incident Report for Toast System

Resolved

Online Ordering processing has recovered successfully.
Posted Feb 13, 2025 - 16:51 EST

Investigating

We are aware of an issue affecting Toast Online Ordering and are investigating. Updates will be provided here as they are available.
Posted Feb 13, 2025 - 16:26 EST
This incident affected: Online Ordering.