Potential Toast Delivery Service Issue
Incident Report for Toast System
Resolved
The Toast system has returned to normal. Thank you for your patience. If you continue to experience issues, please contact Toast Customer Care at (617) 682-0225.
Posted Mar 04, 2021 - 19:40 EST
Investigating
We're investigating a technical issue that has led to a disruption in some restaurant's Toast Delivery orders.

Our engineers are actively working to understand the root cause and to ensure no additional orders are impacted. We will continue to post additional information on this page as it becomes available.
Posted Mar 04, 2021 - 19:24 EST
This incident affected: Online Ordering.