Find Checks Calendar

Incident Report for Toast System

Resolved

A fix has been implemented for this issue. All systems have returned to normal.
Posted Sep 29, 2025 - 19:32 EDT

Identified

We have identified the issue affecting Find Checks and our engineers are working on a fix. Affected customers can still issue refunds by finding the check in their Orders report, selecting Send to Devices, and refunding it from the POS.
Posted Sep 29, 2025 - 18:38 EDT

Investigating

We are aware of an issue causing the calendar on the Find Checks page to fail to load and are investigating. Updates will be provided here as they are available.
Posted Sep 29, 2025 - 17:55 EDT
This incident affected: POS Web application.