Offline Mode 3/29/23
Incident Report for Toast System
Resolved
This incident has been resolved and Toast Systems have returned to normal. Thank you for your patience. If you continue to experience issues, please contact Toast Customer Care at (617) 682-0225.
Posted Mar 29, 2023 - 14:47 EDT
Monitoring
Toast Systems are returning to normal. We will continue to monitor it closely. Thank you for your patience.
Posted Mar 29, 2023 - 14:26 EDT
Investigating
We are aware of an issue affecting Toast Systems and are investigating. Updates will be provided here as they are available.
Posted Mar 29, 2023 - 14:18 EDT
This incident affected: Toast POS app.