Deposit Delay
Incident Report for Toast System
Resolved
The issue impacting deposits has been resolved. Some customers may not have received all or part of the expected deposits from sales on 11/9/2023. We expect these funds to be deposited by the end of business Monday, 11/13/2023, so keep an eye on your bank statement to confirm that your deposit has been made.
Posted Nov 10, 2023 - 17:15 EST
Investigating
We’re investigating an issue with delayed deposits for a subset of customers. We will continue to keep you updated as we identify and resolve this issue.
Posted Nov 10, 2023 - 08:43 EST
This incident affected: Deposits.