Cloud Sync Delays/Latency

Incident Report for Toast System

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 16:22 EDT

Monitoring

A fix has been implemented and we are seeing quick signs of recovery across our systems. We will continue to monitor to ensure this is resolved.
Posted Aug 28, 2025 - 13:33 EDT

Investigating

We are currently aware of and actively investigating an issue with cloud sync delays and latency.
Posted Aug 28, 2025 - 13:13 EDT
This incident affected: Order Processing / KDS, POS Web application, Restaurant Reporting, and Online Ordering.