11/24 - Customer Look-up Issue

Incident Report for Toast System

Resolved

The Customer Look-up tool functionality has been returned to normal and is operating as expected. This incident is now resolved.
Posted Nov 24, 2025 - 12:38 EST

Update

We are still investigating this issue but seeing signs of recovery across some devices.
Posted Nov 24, 2025 - 12:26 EST

Investigating

We are currently aware of an issue with the Customer Look-up Tool on devices where it is stating "Customer Look-up is unavailable while offline" erroneously. This may affect adding guests via the tool to orders, setting up Delivery orders over the phone, as well as prevent adding Loyalty accounts to the orders.
Posted Nov 24, 2025 - 11:56 EST
This incident affected: Order Processing / KDS and Toast POS app.