Toast Retail Issues

Incident Report for Toast System

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 21:04 EDT

Investigating

We are aware of an issue affecting Toast Retail and are investigating. You may experience issues with newly created retail items not showing in your Item Library. Updates will be provided here as they are available.
Posted Aug 13, 2026 - 20:02 EDT
This incident affected: POS Web application.