Toast Status Update - Ireland Support Phone Line Disruption

Incident Report for Toast System

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 11:28 EDT

Identified

We are currently experiencing intermittent connection issues with Ireland Toast Customer Care phone lines. If you are an Ireland based customer experiencing issues reaching Customer Care by phone, please use the following phone number (01) 913 1083 or visit Toast Support Center to chat with a Care agent.
Posted May 30, 2026 - 15:06 EDT
This incident affected: Customer Care Phone Line.