Card processing latency has returned to normal. We are continuing to monitor any impact to other systems. We’ll update you as new information is available.
Posted Aug 21, 2025 - 15:13 EDT
Identified
We have identified an issue which is affecting card processing latency as well as some other errors accessing Toast Systems. Our engineers are working on mitigating the issue. Affected customers can continue using the Background Processing feature within Toast. We’ll update you as new information is available. https://central.toasttab.com/s/article/Offline-Mode-Processing-Credit-Card-Payments
Posted Aug 21, 2025 - 14:36 EDT
Update
We are aware of an issue with credit card processing and we are working diligently to address the issue. You may experience prolonged processing times or receive error messages on some card transactions. Our investigation remains ongoing, and we will share more information as we receive updates.
We are aware of an issue with credit card processing and we are working diligently to address the issue. You may experience prolonged processing times or receive error messages on some card transactions. Our investigation remains ongoing, and we will share more information as we receive updates.