Toast Status Update - Delayed Deposits
Incident Report for Toast System
Resolved
This incident has been resolved. Thank you for your patience. If you continue to experience issues, please contact Toast Customer Care at (617) 682-0225.
Posted Jun 09, 2022 - 16:05 EDT
Monitoring
All customers affected by delayed payment deposits should receive their deposits by 5pm EDT today. Thank you for your patience.
Posted Jun 09, 2022 - 13:03 EDT
Identified
We are aware some customers may have experienced a delay in payment deposits yesterday for the sales date of 6/7. All of these deposits did successfully settle by the end of business yesterday.

We are aware some customers may be experiencing a delay in payment deposits today for the sales date of 6/8. We will update this page with more information as it becomes available.
Posted Jun 09, 2022 - 10:50 EDT
This incident affected: Deposits.