Higher Mastercard Payment Decline Rate

Incident Report for Toast System

Resolved

This incident has been resolved.
Posted Mar 09, 2025 - 09:07 EDT

Investigating

We have been made aware of an issue with Mastercard payments. Customers may experience a higher rate of declined payments when using Mastercard cards. If you receive a declined payment, please attempt to retry the card, use an alternate card or take another form of payment. We will continue to monitor the situation and update when more information is available.
Posted Mar 09, 2025 - 04:41 EDT
This incident affected: Card Processing.